Ελληνικός μικρο-οδηγός για το StarOffice 5.1 Παναγιώτης Κατσαλούλης, <> v0.1.2, 6 Ιουνίου 1999 Αυτό το κείμενο περιγράφει την εγκατάσταση και ελληνικοποίηση του StarOffice 5.1 για το Linux. Γενικές Πληροφορίες

Το StarOffice είναι μια εφαρμογή γραφείου η οποία εμπεριέχει: Επεξεργαστή Κειμένου Λογιστικό Φύλλο Παρουσιάσεις Βάση δεδομένων Φυλλομετρητή για το Internet Ηλεκτρονική αλληλογραφία Ομάδες ενημέρωσης Σχεδιαστικό πακέτο Συγγραφή HTML κειμένων Δημιουργία γραφημάτων, μαθηματικών τύπων Περιβάλλον εργασίας (desktop) και διαχειριστή αρχείων (file manager) Η λειτουργία του στηρίζεται σε ένα WYSIWYG περιβάλλον, το οποίο είναι ιδιαίτερα φιλικό προς τον χρήστη και μοιάζει πολύ με το αντίστοιχο περιβάλλον του πακέτου που άμεσα ανταγωνίζεται (M$Office).

Η τελευταία έκδοση αυτού του μικρο-οδηγού βρίσκεται στη διεύθυνση . Εγκατάσταση του πακέτου Απόκτηση του πακέτου

Το πακέτο έρχεται σαν ένα αρχείο σε tar μορφή. Το όνομά του είναι (για την αγγλική έκδοση 5.1) so51_lnx_01.tar και μπορεί κανείς ελεύθερα να το κατεβάσει απο την διεύθυνση της . Πρέπει να δηλώσει κάποια στοιχεία εκεί. Προσοχή ! Θα ΠΡΕΠΕΙ να σημειώσετε κάπου τα στοιχεία που έχετε δηλώσει σε αυτήν τη σελίδα καθώς και τον κωδικό που σας δίνει γιατί θα χρειαστούν αργότερα. Επίσης προτιμότερο θα ήταν να μην γράψετε όλα σας τα στοιχεία παρά μόνο όσα χρειάζονται για να μειώσετε την πιθανότητα λάθους. Η πολιτική της StarDivision μέχρι τώρα είναι να διαθέτει δωρεάν το συγκεκριμένο πακέτο για προσωπική χρήση. Το μέγεθος του πακέτου είναι περίπου 74Μ. Αποσυμπίεση

Για να το αποσυμπιέσετε χρειάζεται να έχετε τουλάχιστον άλλα 74Μ ελεύθερα. Μπορείτε να το αποσυμπιέσετε με την εντολή tar xvf so*.tar Μετά από αυτό μπορούμε να σβήσουμε το αρχείο so*.tar. Στη συνέχεια πρέπει να εισέλθετε στο φάκελο so51inst. Εκεί θα βρείτε το αρχείο README. Προτείνεται να το διαβάσετε πριν συνεχίσετε. Επίσης στον υποκατάλογο documentation βρίσκεται το αρχείο setup.pdf που περιέχει διάφορες πληροφορίες κυρίως για την εγκατάσταση του πακέτου.

Στην περίπτωση που το σύστημά σας δεν υποστηρίζει την βιβλιοθήκη glibc2 θα πρέπει να την εγκαταστήσετε. Η διαδικασία αυτή μπορεί να γίνει και αυτόματα, αν πάτε στον κατάλογο misc/glibc2 και τρέξετε το soprep, όπως ακριβώς περιγράφεται στο αρχείο README εκεί. Αν δεν εκτελέσετε αυτό το βήμα δεν θα μπορείτε ούτε καν να τρέξετε το πρόγραμμα εγκατάστασης. Αν την έχετε ήδη εγκαταστήσει, μπορείτε να αφήσετε αυτό το στάδιο (όπως π.χ. αν έχετε Redhat 5.2 ή SuSE 6.0 ή ποιο νέες εκδόσεις φυσικά).

ΠΡΟΣΟΧΗ! Μέσα στο README περιγράφει πως για την εγκατάσταση θα πρέπει να σβηστεί το αρχείο /lib/ld-linux-so.2 . Αυτό θα είναι σωστό αν τρέχετε ένα σύστημα βασισμένο σε libc5. Aν όμως το σύστημά σας ΕΙΝΑΙ βασισμένο σε glibc2 τότε ΘΑ ΤΟ ΚΑΤΑΣΤΡΕΨΕΤΕ και μόνο με επανεγκατάσταση θα μπορέσετε να το επαναφέρετε (τουλάχιστον επανεγκατάσταση των βασικών βιβλιοθηκών). Καλύτερα να σιγουρευτείτε πρώτα ότι δεν έχετε glibc2 σύστημα και μετά να αρχίζετε να σβήνετε. Αν μπορείτε να το εγκαταστήσετε το πρόγραμμα χωρίς να εγκαταστήσετε την glibc2, τότε δεν χρειάζεται. Τύποι εγκατάστασης

Μπορείτε να εκτελέσετε δύο τύπους εγκατάστασης Ενός χρήστη Για δίκτυο Υπενθυμίζουμε πως το πρόγραμμα δίνεται δωρεάν μονο αν πρόκειται να το χρησιμοποιήσει ένας χρήστης, οπότε ο κανονικός τρόπος εγκατάστασης είναι αυτός του ενός χρήστη. Πάντως λόγω της μορφής του Linux και λόγω του γεγονότος ότι μπορείτε να έχετε στο σύστημά σας παραπάνω από έναν λογαριασμό, αν και είστε μόνο εσείς αυτός που το χρησιμοποιεί, συνήθως προτιμάται η εγκατάσταση για δίκτυο. Εγκατάσταση για δίκτυο

Η εγκατάσταση εδώ εκτελείται σε δύο στάδια. Στο πρώτο στάδιο εκτελείται μια συνολική εγκατάσταση και στο δεύτερο μια εγκατάσταση για κάθε χρήστη.

Για να αρχίσει η εγκατάσταση πρέπει πρώτα να γίνετε root. Στη συνέχεια πηγαίνετε στον κατάλογο office51 και τυπώστε setup /net. Πρέπει να έχετε κενό χώρο στον σκληρό δίσκο πάνω από 150Μb για να γίνει η εγκατάσταση. Η εγκατάσταση αρχίζει και σας ζητάει πού θα αποθηκευτεί η εφαρμογή. Ο προκαθορισμένος τόπος /opt/Office51 είναι και ο καλύτερος. Αφού τελειώσει η εγκατάσταση μπορείτε να σβήσετε τα αρχείο που έχετε κάνει untar.

Στη συνέχεια πρέπει να εγκαταστήσετε το StarOffice για κάθε λογαριασμό χωριστά. Πρέπει να γνωρίζετε πως για κάθε χρήστη χωριστά χρειάζονται παραπάνω 2Mb. Γίνετε ο χρήστης που γι'αυτόν θέλετε να εγκαταστήσετε το StarOffice. Πηγαίνετε στο /opt/Office51/bin/ και εκτελέστε το αρχείο setup (χωρίς την παράμετρο /net αυτήν τη φορά). Ως όνομα του καταλόγου που θα αποθηκεύσει τα αρχεία του χρήστη δώστε κάτι σαν /home/xrhsths/Office51. Μερικές φορές το StarOffice δε δίνει τα σωστά ονόματα των φακέλων στην εγκατάσταση και πρέπει να τα γράψετε εσείς. Εδώ θα πρέπει να εισάγετε και το όνομά σας και το e-mail όπως ΑΚΡΙΒΩΣ το δηλώσατε όταν κατεβάσατε το αρχείο, καθώς και τον κωδικό που σας είχε δώσει τότε (ελπίζω να είχατε κρατήσει σημειώσεις...). Εγκαθιστά τα αρχεία και τελειώσατε! Δήλωση προϊόντος

Στην έκδοση 5.1 του StarOffice έχει βελτιωθεί η όλη διαδικασία της δήλωσης προϊόντος. Παρακάτω περιγράφεται πώς γίνεται η δήλωση για την έκδοση 5.0.

Για να μπορέσουμε να χρησιμοποιήσουμε το StarOffice χωρίς κανέναν περιορισμό θα πρέπει να τον δηλώσουμε στην StarDivision πρώτα. Αυτό μας το ζητάει το ίδιο το πρόγραμμα με το που ξεκινάμε. Η διαδικασία είναι απλή αρκεί να έχουμε ενεργή σύνδεση με το internet εκείνη τη στιγμή που γίνεται η δήλωση. Τα βήματα που πρέπει να ακολουθήσουμε είναι τα εξής: Διαλέγουμε "No" στο παράθυρο διαλόγου που μας ρωτάει αν θέλουμε να δηλώσουμε τώρα το StarOffice. Πηγαίνουμε στο "Tools" - "Options" - "General ..." - "User data" και συμπληρώνουμε τα στοιχεία μας - αν θέλουμε :-) Πηγαίνουμε στο "Tools" - "Options" - "Interent ..." - "Protocol" - "DNS server" και διαλέγουμε "Automatic" και "ΟΚ". Μερικές φορές χρειάζεται να βγούμε από το StarOffice για να ενεργοποιηθούν οι αλλαγές στο internet. Συνδεόμαστε με το intenet όπως πάντα. Ανοίγουμε το StarOffice (αν το είχαμε κλείσει). Πηγαίνουμε στο "Help" - "Registration" - "Register..." Πατούμε το "Send >>". Αν όλα πήγαν καλά θα μας πει πως η δήλωση έγινε επιτυχώς. Αν πει "Read error. Could not resolve hostname support.stardiv.de" σημαίνει πως είτε δεν έχετε συνδεθεί σωστά με το Internet ή δεν βάλατε Automatic DNS server. Μετά από λίγο θα σας έρθει e-mail με το νέο κωδικό σας. Τότε γράψτε σε ένα χαρτί ακριβώς τα στοιχεία που έχετε δηλώσει στο User Data καθώς και το Customer number και το Registration key. Αν αργότερα θέλετε να επανεγκαταστήσετε το StarOffice δεν χρειάζεται να το δηλώσετε πάλι. Αρκεί να ακολουθήσετε αυτήν την διαδικασία και αντί να πατήσετε το κουμπί "Register..." να γράψετε τα πεδία Customer number και Registration key και μετά πατήστε το "Enable key". Αν δεν μπορείτε να διαλέξετε αυτό το κουμπί σημαίνει πως γράψατε κάτι λάθος ή δεν έχετε δηλώσει τα στοιχεία σας ακριβώς όπως την πρώτη φορά. Εγκατάσταση πληκτρολογίου

Το StarOffice ευτυχώς δεν είναι απαιτητικό με το πληκτρολόγιο. Έχει δοκιμαστεί με τα παρακάτω πακέτα και η ανταπόκρισή του ήταν άψογη. kikbd (από το KDE 1.1.1) grISOXKb-1.2 XFGreekKBD-1.2 GRkbd-1.2 Προσωπικά θα συνιστούσα το kikbd γιατί είναι το ποιό πλήρες. Πριν την εκτέλεση του soffice θα πρέπει να έχετε εκτελέσει την εντολή "export _XKB_CHARSET=iso8859-7" την οποία καλό θa ήταν να την βάλετε π.χ. στο .bashrc για να την τρέχουν όλα τα προγράμματα. Εγκατάσταση Ελληνικών γραμματοσειρών

Ευτυχώς για μας, η εγκατάσταση των γραμματοσειρών στο StarOffice 5.1 έχει ουσιαστικά βελτιωθεί σε σχέση με το παρελθόν. Τώρα μερικά βήματα ή είναι άχρηστα ή γίνονται αυτόματα. Η εγκατάσταση των ελληνικών γραμματοσειρών γίνεται όπως κάθε εγκατάσταση γραμματοσειρών για το StarOffice και χωρίζεται σε δύο στάδια: στην εγκατάσταση στον X-server και στην εγκατάσταση στο StarOffice. Εγκατάσταση ελληνικών γραμματοσειρών από το εγχείρημα ΓΡΑΦΙΣ

Ευτυχώς πλέον με το εγχείρημα ΓΡΑΦΙΣ η εγκατάσταση των ελληνικών γίνεται αβίαστα και πανεύκολα. Πηγαίνετε στη σελίδα του και κατεβάστε το πακέτο που ταιριάζει καλύτερα στο σύστημά σας. Αν το έχετε ήδη κάνει δεν χρειάζεται τίποτε περισσότερο από το να δηλώσετε αυτές τις γραμματοσειρές στο StarOffice. To πακέτο xfntgr έχει όλες τις ελληνικές γραμματοσειρές, όχι μόνο τις graphis-arial. Δήλωση γραμματοσειρών στο StarOffice

Το τελευταίο βήμα για να δουλέψουν οι γραμματοσειρές με το StarOffice είναι να δηλώσουμε τις γραμματοσειρές αυτές στο StarOffice. Πρέπει όμως να είμαστε root για να γίνει αυτό. Πηγαίνουμε στο φάκελο /opt/Office*/bin και εκτελούμε το αρχείο Γνωστά προβλήματα είναι ότι τα BOLDITALIC των grinet-greek arial grinet-greek times και grinet-greek courier δεν εμφανίζονται. Εγκατάσταση άλλων ελληνικών γραμματοσειρών

Στο θέμα αυτό δεν θα αναφερθώ εκτεταμένα. Υπάρχει αρκετή βιβλιογραφία γι'αυτό (σημ.: όποιος θέλει να βοηθήσει ας μου στείλει την http διεύθυνση για αυτό το θέμα). Πρέπει να τονισθεί πως μόνο οι Type1 γραμματοσειρές είναι για εκτύπωση (για οποιαδήποτε εφαρμογή) ενώ οι Bitmap δεν είναι.

Σε γενικές γραμμές τα βήματα που πρέπει να κάνει κανείς είναι: Αποσυμπίεση του αρχείου με τα ελληνικά (αν είναι συμπιεσμένο). Έλεγχος αν υπάρχει το αρχείο Δημιουργία των αρχείων . Για να σχηματιστούν πρέπει να πάτε στον κατάλογο που μόλις έχετε αποσυμπιέσει τα ελληνικά και να τρέξετε το πρόγραμμα type1inst. (Πρώτα πρέπει να το έχετε αποσυμπιέσει και κάνει executable: Να δηλώσετε στα X το νέο φάκελο με τις γραμματοσειρές. Αυτό γίνεται με δύο τρόπους: ορίζοντας το νέο φάκελο στο αρχείο /etc/ ή /etc/X11/. Ο ορισμός γίνεται ως εξής: Section "Files" FontPath "/my/font/path" Μη ξεχάσετε να αλλάξετε το παραπάνω παράδειγμα στη σωστή διαδρομή του δίσκου! Προσοχή ! Αν για οποιοδήποτε λόγο τα αρχεία στον κατάλογο των γραμματοσειρών που μόλις δηλώσατε δεν μπορούν να διαβαστούν σωστά από τα Χ, εκτελώντας τις παρακάτω εντολές στο αρχείο xset +fp /my/font/path xset fp rehash Έλεγχος ότι οι γραμματοσειρές εγκαταστάθηκαν. Αυτό γίνεται τρέχοντας το πρόγραμμα Βελτιστοποίηση αρχείων afm

Δυστυχώς τα περισσότερα αρχεία afm που έρχονται μαζί με τις γραμματοσειρές δεν μπορούν να χρησιμοποιηθούν ως έχουν με το StarOffice. Πρέπει να έχουν τα δεδομένα τους σε μια συγκεκριμένη σειρά και να έχουν ορισμένα πεδία έτσι δηλωμένα που ενώ δεν είναι χρήσιμα για τα Χ, είναι ωστόσο απαραίτητα για το StarOffice. Για να γίνει η ζωή μας πιο εύκολη υπάρχει το πρόγραμμα σε perl το οποίο αυτόματα δημιουργεί το σωστό afm αρχείο. Το αρχείο αυτό μπορεί να διαβαστεί και από τα Χ, οπότε δεν υπάρχει φόβος να καταστρέψετε αυτό το αρχείο. Για να τα μετατρέψετε πρέπει να πάτε στον φάκελο με τις γραμματοσειρές greekXfonts-Type1 και να εκτελέσετε τις επόμενες εντολές: perl afm.pl fontname.afm rm -f fontname.afm mv fontname.afm.new fontname.afm Φυσικά αν σας έχουν πει πως οι συγκεκριμένες γραμματοσειρές έχουν afm αρχείο συμβατό με StarOffice δεν χρειάζεται αυτό το βήμα. Διόρθωση βοηθητικών αρχείων

Αυτό το βήμα κανονικά δεν θα έπρεπε να γίνεται, τουλάχιστον για όσες γραμματοσειρές έχουμε εκτελέσει το πρόγραμμα Ευτυχώς αν έχετε κατεβάσει την έκδοση από το εγχείρημα ΓΡΑΦΙΣ όλα αυτά τα βήματα έχουν ήδη γίνει. Οι πληροφορίες υπάρχουν εδώ μόνο αν θέλετε να μάθετε τι ακριβώς έγινε.

Αφήνουμε το πρόγραμμα #-grinet-greek courier-medium-r-normal--0-0-0-0-m-0-iso8859-7 -grinet-greek courier-medium-r-normal--0-0-0-0-m-0-iso8859-1 #-grinet-greek courier-bold-r-normal--0-0-0-0-m-0-iso8859-7 -grinet-greek courier-bold-r-normal--0-0-0-0-m-0-iso8859-1 #-grinet-greek courier-medium-i-normal--0-0-0-0-m-0-iso8859-7 -grinet-greek courier-medium-i-normal--0-0-0-0-m-0-iso8859-1 #-grinet-greek courier-bold-i-normal--0-0-0-0-m-0-iso8859-7 -grinet-greek courier-bold-i-normal--0-0-0-0-m-0-iso8859-1 #-grinet-greek times-medium-r-normal--0-0-0-0-p-0-iso8859-7 -grinet-greek times-medium-r-normal--0-0-0-0-p-0-iso8859-1 #-grinet-greek times-bold-r-normal--0-0-0-0-p-0-iso8859-7 -grinet-greek times-bold-r-normal--0-0-0-0-p-0-iso8859-1 #-grinet-greek times-medium-i-normal--0-0-0-0-p-0-iso8859-7 -grinet-greek times-medium-i-normal--0-0-0-0-p-0-iso8859-1 #-grinet-greek times-bold-i-normal--0-0-0-0-p-0-iso8859-7 -grinet-greek times-bold-i-normal--0-0-0-0-p-0-iso8859-1 #-grinet-greek arial-medium-r-normal--0-0-0-0-p-0-iso8859-7 -grinet-greek arial-medium-r-normal--0-0-0-0-p-0-iso8859-1 #-grinet-greek arial-bold-r-normal--0-0-0-0-p-0-iso8859-7 -grinet-greek arial-bold-r-normal--0-0-0-0-p-0-iso8859-1 #-grinet-greek arial-medium-i-normal--0-0-0-0-p-0-iso8859-7 -grinet-greek arial-medium-i-normal--0-0-0-0-p-0-iso8859-1 #-grinet-greek arial-bold-i-normal--0-0-0-0-p-0-iso8859-7 -grinet-greek arial-bold-i-normal--0-0-0-0-p-0-iso8859-1 Επειδή εδώ που διαβάζετε αυτό το κείμενο είναι πιθανόν να μη φαίνονται στην ίδια γραμμή όλα όσα θα έπρεπε να ήταν στην ίδια γραμμή, σημάδεψα με το σύμβολο # κάθε νέα γραμμή. Φυσικά εσείς όταν θα διορθώσετε το αρχείο θα πρέπει να ΜΗΝ βάλετε αυτό το σύμβολο.

Ένα άλλο πρόβλημα είναι με τα ονόματα των γραμματοσειρών. Ο "απλός" χαρακτήρας αυτών των γραμματοσειρών (δηλαδή ούτε έντονος ούτε πλαγιαστός) έχει διαφορετικό όνομα από ότι οι πλαγιαστοί και οι έντονοι. Αυτό διορθώνεται εύκολα κάνοντας μια μικρή επέμβαση στα αρχεία που δημιούργησε το -grinet-greek times plain-... Εσείς θα πρέπει να το διορθώσετε σε -grinet-greek times- σκέτο, χωρίς plain. Το ίδιο θα κάνετε και για το arial κλπ. Ευτυχώς που το StarOffice αναγνωρίζει αυτόματα αυτό το σημείο. Ελληνικοποίηση του StarOffice

Σε αυτό το σημείο θα περιγράψουμε πως να εξελληνίσουμε όσο είναι πιο δυνατόν το StarOffice. Πρέπει όμως να τονίσω πως κάποιες τέτοιες παράμετροι "κρεμούν" το StarOffice και δυστυχώς δεν έχω ακόμα ανακαλύψει ποιες. Αυτό που προτείνω είναι να κρατάτε συχνά αντίγραφο ασφαλείας του φακέλου /home/myaccount/Office*/ για να έχετε το κεφάλι σας ήσυχο. Προσοχή: αυτό δεν σημαίνει πως καταστρέφονται τα αρχεία που φτιάχνετε. Δεν συμβαίνει αυτό. Εκείνο που γίνεται είναι ότι το StarOffice κρασάρει με το που πάει κανείς να κάνει κάτι χρήσιμο.

Το σημείο του οδηγού αυτού είναι ακόμα υπό κατασκευή (και υπό αναζήτηση πληροφοριών).

Για να αλλάξει κανείς τη γραμματοσειρά που χρησιμοποιεί το StarOffice για να εμφανίσει τους διαλόγους, τα παράθυρα κλπ. πρέπει να πάει στο "Tools" - "Options" - "General..." - "Substitute Font". Εκεί ενεργοποιεί το "Apply replacement table". Από την επιλογή "Font" διαλέγει την "lucida" και δίπλα στην επιλογή "Replace with" διαλέγει την ελληνική γραμματοσειρά της αρεσκείας του. Φυσικά έτσι δεν θα μπορεί πλέον να χρησιμοποιεί την γραμματοσειρά "Lucida" στα έγγραφα του, αλλά δεν νομίζω να είναι απαραίτητη! Πάντως αν πάλι δεν βλέπετε ελληνικά, πρέπει να φταίει πως η γραμματοσειρά που διαλέξατε υπάρχει και σε ελληνικό και σε ευρωπαϊκό σύνολο χαρακτήρων, οπότε καλύτερα να διαλέξετε μια άλλη που έχει μοναδικό όνομα.

Για να αλλάξετε τον τρόπο μέτρησης από ίντσες σε εκατοστά πηγαίνετε στο "Tools" - "Options" - "Text Document..." - "Layout" και αλλάξτε το "Meas. units" σε χιλιοστά ή εκατοστά. Το ίδιο κάνετε και για τις άλλες μορφές εγγράφων (HTML, Spreadsheet, Presentation κλπ.)

Για να αλλάξετε τις προκαθορισμένες γραμματοσειρές πηγαίνετε στο "Tools" - "Options" - "Text Document..." - "Standard Fonts" και εκεί να ορίσετε τις επιθυμητές γραμματοσειρές. Επίσης, αν θέλετε ανοίγοντας τον Stylist να αλλάξετε τις προκαθορισμένες γραμματοσειρές για κάθε στυλ. Μπορεί ακόμα και να αλλάξει σε ελληνικά εισαγωγικά. Αρκεί να πάει στο "Tools" - "AutoCorrect/AutoFormat..." - "Custom Quotes" - "Single Quotes" - "Replace" ναι να αλλάξει τα "Start Quote" και "End Quote" σε << και >> αντίστοιχα (171 και 187). Δυστυχώς δεν έχω βρει ακόμα πού αποθηκεύονται αυτές οι αλλαγές.

Μπορεί όντως να έχει κανείς ελληνικό λεξικό διόρθωσης λαθών! Για να χρησιμοποιήσει θα πρέπει όμως να έχει αλλάξει (φυσικά) τη βασική γραμματοσειρά. Η διαδικασία όμως είναι δύσκολη και καθόλου πρακτική (τουλάχιστον προς το παρόν. Για το μέλλον θα δούμε τι μπορεί να γίνει.

Επίσης μπορεί κανείς να φτιάξει έτοιμες νέες λίστες με τις μέρες της εβδομάδας ή τους μήνες για παράδειγμα.

Οποιοσδήποτε έχει βρει κάποια πληροφορία η οποία θα ήταν χρήσιμη για αυτό το κείμενο παρακαλείται να μου γράψει! Εξωτικές γραμματοσειρές: TTF και Unicode

Υπό κατασκευή.

Βασικά με τις TTF γραμματοσειρές δεν μπορεί κανείς να τυπώσει στο Linux. Μπορεί όμως άνετα να τις δει αν έχει εγκαταστήσει έναν εξυπηρετητή γραμματοσειρών TTF. Αν θέλει να τυπώσει κιόλας θα πρέπει να μετατρέψει τις γραμματοσειρές αυτές σε Type1 και να τις χρησιμοποιήσει έτσι.

Αν οι γραμματοσειρές είναι Unicode, ναι μεν το StarOffice τις αναγνωρίζει και τις τυπώνει, τα Χ όμως όχι! Αυτό έχει ως αποτέλεσμα να μη φαίνονται σωστά στην οθόνη. Μετατροπή TTF γραμματοσειρών σε Type1

Αυτή είναι και η μοναδική μέθοδος σύμφωνα με την StarDivision προκειμένου να τυπώσουμε με γραμματοσειρές TTF. Δυστυχώς όμως μετατρέποντας τες σε Type1 χάνουν πολύ σαν ποιότητα στην εμφάνιση όχι λόγω της μετατροπής αλλά λόγω των άσχημων ρουτινών που έχουν τα Χ για να εμφανίσουν Type1 στην οθόνη. Η διαδικασία είναι η εξής: Αποκτούμε τα αρχείο και . Τα αποσυμπιέζουμε και μεταφέρουμε τα εκτελέσιμα αρχεία κάπου που μπορούν να βρεθούν αυτόματα, π.χ. στο &tilde/bin/ μαζί με το αρχείο Για κάθε ένα TTF αρχείο εκτελούμε τις εξής εντολές (έστω ttf2pfa myfont.ttf myfont ttf2pt1 myfont.ttf myfont t1asm -b myfont.pfa >myfont.pfb rm -f myfont.pfa afm.pl myfont.afm rm myfont.afm mv myfont.afm.new myfont.afm Επειδή η όλη δουλειά για κάθε αρχείο TTF είναι ιδιαίτερα κουραστική, έφτιαξα ένα για να γίνεται η δουλειά πιο γρήγορα. Αφού το κατεβάσετε το αποσυμπιέζετε, το βάζετε μαζί με τα άλλα και το μετατρέπετε σε εκτελέσιμο. Πηγαίνετε τότε στον κατάλογο που έχετε τα TTF αρχεία και το εκτελείτε. Κανονικά όλα θα πρέπει να δουλέψουν ρολόι, αν δεν έχετε ξεχάσει τίποτα. Από εδώ και στο εξής η διαδικασία είναι όπως περιγράφτηκε στην εγκατάσταση γραμματοσειρών. Για ελληνικές γραμματοσειρές ελέγξτε πρώτα αν είναι ή όχι Unicode, αλλιώς δεν θα μπορείτε να τις βλέπετε στην οθόνη σωστά. Βιβλιογραφία

Star Office 5.1 SETUP.PDF Διάφορες πληροφορίες

Ευχαριστίες

Ευχαριστώ τους εξής: Tην ομάδα ΓΡΑΦΙΣ για την προσπάθειά τους να δημιουργήσουν ένα πακέτο ελληνικών ΕΥΚΟΛΟ, ΑΜΕΣΟ, ΣΩΣΤΟ και ΩΡΑΙΟ (αν δεν παινέψεις το σπίτι σου...) Σωτήρης Τσιμπόνης για την βοήθειά του να εγκαταστήσω ελληνικά στο SuSE Linux που έχω. Γεράσιμος Τουμαζάτος για τη βοήθεια στην εγκατάσταση ελληνικών γραμματοσειρών στο StarOffice. Ανάδραση

Κάθε σχόλιο είναι όχι μόνο ευπρόσδεκτο αλλά και επιθυμητό.

Παναγιώτης Κατσαλούλης, <>

HTTP: Πολιτική Διανομής

Copyright (c) 1998-1999 από τον Παναγιώτη Κατσαλούλη.

Αυτό το κείμενο μπορεί να διατίθεται σύμφωνα με τους όρους που περιγράφονται στην άδεια χρήσης LDP στο